Рабочем Столе, или выбрать одноименную коман­ду из меню Пуск icon

Рабочем Столе, или выбрать одноименную коман­ду из меню Пуск




Скачать 219.58 Kb.
НазваниеРабочем Столе, или выбрать одноименную коман­ду из меню Пуск
Дата04.04.2013
Размер219.58 Kb.
ТипДокументы
источник


Программный интерфейс

Интерфейс K0MIIAC-3D V6 прост и интуитивно понятен. Разработчики это­го программного продукта постарались сделать его максимально эргономич­ным, а работу — максимально эффективной.

Для запуска программы необходимо дважды щелкнуть мышью по знач­ку, расположенному на Рабочем Столе, или выбрать одноименную коман­ду из меню Пуск (по умолчанию Пуск | Программы | Аскон | Компас-ЗD V6, (рис. 1.3).



После того как вы запустили программу, перед вами появится окно, пока­занное на рис. 1.4. При первом запуске в нем мало кнопок и выглядит оно не особенно привлекательно.

Но как сказал один эпизодический герой известного фильма: «... но это только кажущаяся видимость!». И вы в этом убедитесь.

Чтобы сделать работу в среде KOMIIAC-3D максимально удобной, разработ­чики предусмотрели возможность настройки интерфейса индивидуально для каждого пользователя и в зависимости от выполняемых задач. Рассмотрим элементы интерфейса KOMIIAC-3D V6 поподробнее.

Вне зависимости от того, с какими документами вы работаете, на экране всегда отображаются ^ Главное меню и панели инструментов Стандартная, Вид, Текущее состояние, Компактная.







В верхней части главного окна расположена панель ^ Главное меню (рис. 1.5).

Главное меню содержит разнообразные команды, необходимые при работе с программой. Каждый пункт Главного меню — это выпадающее меню, содержа­щее команды редактирования, о назначении которых можно судить по его назва­нию. Чтобы воспользоваться командой из такого подменю, щелкните левой кноп­кой мыши по его названию. Раскроется список доступных команд, из которого вы можете выбрать нужную и запустить ее нажатием левой кнопкой мыши.

Панель инструментов Стандартная служит для вызова команд работы с файлами и объектами (рис. 1.6).



На панели Вид (рис. 1.7) расположены кнопки для вызова команд настрой­ки отображения активного документа. Вид этой панели зависит от типа доку­мента, с которым вы работаете.



Панель ^ Текущее состояние (рис. 1.8) отображает текущую информацию о состоянии активного документа, вид, слой, масштаб отображения, шаг курсора по сетке, текущие координаты курсора. Набор кнопок и полей, отобра­жаемых на этой панели, зависит от типа документа, с которым вы работаете.

Компактная панель (рис. 1.9) дает возможность быстрого доступа к нуж­ным панелям инструментов. Заметим, что состав Компактной панели также зависит от типа активного документа. По желанию его можно изменить.

Для удаления кнопок, активизирующих определенную панель необходимо выполнить следующее:

  1. Подведите мышь к маркеру перемещения, который находится под кнопкой.

  2. Щелкните по нему (маркер мыши примет вид перекрестья) и, не отпус­кая, перетащите в любую область рабочего окна.

Добавление кнопки осуществляется практически аналогично:

  1. Выберите панель.

  2. Подведите мышь к маркеру перемещения (у панели он находится сле­ва).

  3. Щелкните мышью и, не отпуская, перетащите в область кнопок Ком­пактной панели.



Панель инструментов Компактная облегчает переключение между инстру­ментальными панелями и экономит поле рабочей области.

^ Панель свойств предназначена для управления процессом выполнения ко­манды.

Вкладки Панели свойств (рис. 1.10) содержат поля и переключатели, при помощи которых можно непосредственно определять параметры создаваемых

объектов и определять их свойства. Количество вкладок зависит от конкрет­ной команды. Чтобы перейти на нужную вкладку, щелкните по ней левой кнопкой мыши.

В верхней части ^ Панели свойств (рис. 1.11) расположена Панель специ­ального управления, которая позволяет контролировать процесс выполнения текущей команды.



При работе с разными типами документов требуются различные панели, поэтому присутствие на экране всех панелей сразу не требуется.

Любую панель можно активизировать, воспользовавшись соответствующей командой из меню Вид (рис. 1.12).



При работе в среде КОМПАС-ЗБ V6 часто приходится работать с перемен­ными и описывать уравнениями некоторые состояния объектов. Для этого слу­жит панель Переменные.

Для управления библиотеками служит Менеджер библиотек. На этой пане­ли (рис. 1.13) расположены несколько вкладок.

На первой вкладке в виде дерева отображается перечень библиотек. В пра­вой части окна показаны возможные для подключения библиотеки. Если в вы­бранном разделе уже есть подключенные библиотеки, то он отображается се­рым цветом, в противном случае — голубым. Подключенные библиотеки отме­чены красной галочкой. В любое время при работе с системой можно подклю­чить требуемую библиотеку.



При работе со сборками и деталями используется панель ^ Дерево построе­ния. Она представляет собой перечень элементов в виде дерева, составляющих деталь или сборку. Дерево построения (рис. 1.14) служит для упрощения вы­бора объектов в процессе редактирования, любой объект после создания авто­матически в нем отображается.






В нижней части главного окна расположена строка сообщений (рис. 1.15), которая комментирует действия в соответствии с выбранной командой.

При работе с разными документами удобно использовать ^ Контекстные меню. Контекстное меню вызывается нажатием правой кнопки мыши в области редак­тируемого документа и зависит от типа объекта, с которым вы работаете.

О работе с ^ Контекстным меню более подробно будет рассказано в других главах книги на конкретных примерах.

Для работы с книгой необходимо настроить интерфейс. Для этого:

  1. Запустите KOMIIAC-3D V6, в результате откроется главное окно системы.

  2. Создайте нужный документ (допустим, фрагмент). Для этого щелкните мышью по кнопке Щ} (Создать) или выберите из Главного меню Файл | Создать... Появится окно Новый документ.

  3. На вкладке Новые документы выберите Фрагмент. Щелкните по кноп­ке ОК.

  4. Выберите из Главного меню Вид | Панели инструментов | Панель свойств.

  5. Разместите ее в нижней части окна (как перетащить панель было рас­сказано выше).

  6. Выберите из Главного меню Сервис | Настройка интерфейса... Поя­вится одноименное окно.

  7. На вкладке Панели инструментов отметьте галочками панели Стан­дартная, Ассоциативные виды, Вид, Геометрия, Компактная панель, Меню, Текущее состояние, Форматирование.

  8. Расположите выбранные панели в порядке, указанном на рис. 1.16.



Панели также можно выбирать с помощью контекстного меню (рис. 1.17). Для этого щелкните на любой панели правой кнопкой мыши и выберите в поя­вившемся меню необходимые.







Рассмотрим Главное меню программы (рис. 1.18, 1.19).

Данный элемент интерфейса является контекстно-зависимым, то есть его содержание зависит от типа документа, с которым вы работаете. Но есть ряд пунктов этого меню (Файл, Вид, Сервис, Справка, Библиотеки), которые дос­тупны всегда — вне зависимости от редактируемого документа. Но важно от­метить, что их содержимое может изменяться.

Более подробно с каждым из пунктов ^ Главного меню вы познакомитесь да­лее, в процессе разработки моделей и чертежей. А пока рассмотрим общее на­значение каждого из меню.

Файл

В выпадающем меню ^ Файл (рис. 1.20) находятся основные команды работы с файлами документов — Создать, Открыть, Сохранить и т.п. Обратите вни­мание, что многие команды Главного меню имеют «горячие» клавиши, при помощи которых вы можете быстро вызвать команду. Наличие таких клавиш существенно ускоряет работу с документами, поэтому, если вы хотите сущест­венно облегчить процесс проектирования, полезно помнить о них.

Здесь же находятся команды предварительного просмотра документа — вы можете оценить, как, например, созданный вами чертеж будет выглядеть на листе, и команда вывода документа на печать.

Обратите внимание, что в нижней части меню находится список недавно ре­дактированных документов. Вы можете начать работу с документом, просто выбрав его из этого списка.







Редактор

Как видно из названия, в данном пункте меню расположены команды редак­тирования документов. Этот пункт меню является контекстно-зависимым. На­пример, при работе с трехмерными моделями, как деталей, так и сборок, в этом меню находятся команды редактирования их элементов (рис. 1.21).

Если же вы работаете, например, с текстовым документом, то здесь можно найти основные команды редактирования текста: Найти, Заменить, Копиро­вать, Вставить и т.п. (рис. 1.22).



Вид

В этом пункте меню находятся команды настройки интерфейса и управле­ния изображением документа (рис. 1.23).



Вы уже немного познакомились с данным меню в предыдущей главе — вы использовали его команды для настройки интерфейса. Однако здесь есть еще ряд полезных команд, необходимых непосредственно при работе с документа­ми. Эти команды позволяют изменять отображение документа, перестраивать созданные модели, масштабировать изображение на мониторе и т.д.

Сервис

В меню Сервис (рис. 1.24) находятся команды, при помощи которых можно настроить вид документа, тип линий, произвести настройки интерфейса, а также производить различные расчеты (массо-центровочных характеристик моделей, площадей поверхностей, объемов и т.д.). Это меню также является контекстно-зависимым.



Библиотеки

В данном пункте меню содержится перечень всех подключенных библиотек (рис. 1.25). Если вы хотите воспользоваться элементами активной библиотеки, то просто войдите в это меню и щелкните по названию нужной библиотеки.



Прочие меню

Теперь рассмотрим пункты ^ Главного меню, появляющиеся в зависимости от типа документа, с которым вы работаете.

При работе с трехмерными моделями деталей и сборок Главное меню вы­глядит так, как изображено на рис. 1.26.



  • Операции. Данный пункт Главного меню содержит команды создания эскизов, различных формообразующих элементов (Выдавливание, При­соединение и т.п.), вспомогательных геометрических построений (Осей, вспомогательных плоскостей и т.д.). Представленные здесь команды идентичны тем, которые находятся на Компактной панели инструмен­тов;

  • Спецификация. Как видно из названия в данном пункте меню находятся команды работы со спецификациями. При помощи этого меню вы може­те управлять элементами спецификации, автоматически создать специ­фикацию для модели сборки и т.д.;

  • Окно. При помощи этого меню вы можете переключаться между откры­тыми окнами различных документов, задать одновременное отображение нескольких документов, определить схему размещения окон и т.д. Дан­ное окно помогает оптимизировать одновременную работу с несколькими документами.




Если вы работаете с текстовыми документами или спецификациями, то Главное меню будет выглядеть как на рис. 1.27.

Вставка. Данный элемент Главного меню является контекстно зависи­мым. Так, если вы работаете с текстовым документом, то здесь находятся команды вставки специальных символов, таблиц, файлов и т.д.

(рис. 1.28). При работе же со спецификациями, кроме указанных выше команд, здесь вы можете найти и команды создания разделов специфика­ции и вставки объектов (рис. 1.29);



  • Формат. При работе со спецификациями при помощи этого пункта глав­ного меню можно произвести необходимые настройки редактируемого документа. В то время как содержание данного меню при работе с тексто­выми документами очень похоже на аналогичный пункт меню обыкно­венного текстового редактора, например, MS Word. Здесь вы можете най­ти команды настройки шрифтов, форматирования абзацев, стилей, соз­дания списков и т.д. (рис. 1.30);

  • Таблица. Данный элемент Главного меню содержит команды работы с таблицами и управления ее элементами.



И, наконец, если вы работаете с чертежами или фрагментами, то Главное меню выглядит так, как показано на рис. 1.31.



  • Выделить. В данном меню находятся команды выделения элементов чер­тежей, при помощи которых вы можете выделить вид, слой, отдельные примитивы и т.д. Команды этого меню очень полезно использовать при проработке компоновки чертежа. Заметьте, что аналогичные команды можно найти на Компактной панели инструментов;

  • Вставка. В этом меню вы можете найти команды создания нового слоя, локальной системы координат, вставки рисунков и файлов, что очень по­лезно для создания документов, содержащих графические элементы;

  • Инструменты. Данное меню содержит инструменты построения, напри­мер, Отрезок, Окружность и т.д., нанесения размеров и обозначений, ко­манды параметризации.


Типы документов

В КОМПАС существует несколько типов документов — часть из них отно­сится к трехмерному моделированию, а часть — к чертежам. Каждому типу документа соответствует файл с определенным разрешением. Рассмотрим типы документов в КОМПАС.1. Трехмерные модели. Существует два типа документов трехмерных мо­делей: документы-детали и документы-сборки. При этом первому типу соответствуют файлы с разрешением .m3d, а второму — .a3d.о Деталь *- это модель, созданная из однородного материала. При соз­дании детали вы не можете выполнять никакие сборочные операции; Сборка — это модель, созданная из различных деталей с применени­ем сборочных операций (то есть с использованием болтов, винтов и прочих типов соединений).

^ 2. Графические документы. К этому типу относятся чертежи моделей и их элементов. В КОМПАС существует две разновидности графических доку­ментов: чертежи и фрагменты. К чертежам относятся все изображения, оформленные в соответствии с ГОСТ (то есть на формате, с рамкой, штампом и т.п.). Файлы чертежей имеют расширение .cdw. Фрагментов отличие от чертежа не имеет рамки и штампа — это вспомогательный документ в КОМПАС, файл фрагмента имеет расширение .frw.

^ 3. Текстовые документы. Данный тип документов — это, как правило, сопроводительная конструкторская документация: спецификации, таб­лицы составных частей, пояснительные записки и т.п. В КОМПАС раз­личают два вида текстовых документов — спецификация и текстовый документ. Спецификация — это документ, который содержит информа­цию о деталях сборки, она оформляется в виде таблицы в рамке с основ­ной надписью. Файлы спецификаций имеют расширение .spw. Тексто­вый документ — это любой документ, содержащий текст. Как правило, такие документы также оформляются на листах с рамкой и основной надписью. Файлы тестовых документов имею расширение .kdw.

Создание документов

Существует два способа создания документов. Вы можете воспользоваться меню, либо соответствующей кнопкой на панели инструментов. Для того чтобы создать новый документ:

  1. Из меню Файл выберите команду Создать или нажмите клавиши Ctrl+N.

  1. В появившемся диалоговом окне (рис. 1.32) щелкните по пиктограмме документа, который вы хотите создать.

Или:

1. Щелкните по кнопке (Создать), расположенной на панели инстру­ментов. Откроется диалоговое окно, показанное на рис. 1.32, в нем вы­берите тип документа, который вы хотите создать.



Настройки формата

При создании чертежа вам может потребоваться изменить формат листа, чтобы как можно лучше осуществить компоновку, изменить шрифт, зачер­нять стрелки, изменять внешний вид отдельных элементов. Все это можно осуществить, произведя соответствующие настройки формата.

Для того чтобы получить доступ к настройкам формата:

  1. Создайте новый документ типа Чертеж.

  2. Щелкните правой кнопкой мыши и из появившегося меню выберите пункт Параметры текущего чертежа (рис. 1.33).

  3. Появится окно Параметры, изображенное на рис. 1.34, вкладка Теку­щий чертеж. В правой части окна приведен список настроек, которые можно выполнить для создаваемого чертежа.

Вам доступны следующие настройки:

^ Шрифт по умолчанию. В данном пункте настроек вы можете выбрать шрифт, который будет использоваться для всех текстовых надписях в до­кументе;





  • Единицы измерения. В системе КОМПАС используются единицы изме­рения системы СИ. Для работы с программой вы можете использовать миллиметры, сантиметры или метры;

  • Зачернение стрелок. Этой настройкой вы можете задать, зачернять стрелки или нет (рис. 1.35);

  • Размеры. Заметьте, что справа от этого пункта стоит знак «плюс». Это означает, что настройка имеет список параметров. Чтобы открыть этот список, щелкните по знаку «плюс». Заметьте, что при открытии списка знак рядом с пунктом Размеры изменился на «минус». Это означает, что список настроек раскрыт. Если вы хотите закрыть его, щелкните по зна­ку «минус» (рис. 1.36):

о Параметры. Здесь вы можете задать параметры выносной линии размеров, стрелок и т.п.;

о Надпись. Данная настройка определяет параметры текста, который будет использоваться при простановке размеров на чертеже;

о Точности. Программа КОМПАС при простановке размеров автома­тически вычисляет их. При помощи этой настройки вы можете за­дать точность, с которой они будут отображаться на чертеже;



• Линия-выноска. Данный пункт настроек имеет также ряд опций (рис. ^ 1.36):

о Текст над/под полкой;

о Наклонный текст;

о Текст обозначения позиций;

о Размеры знаков. Как видно из названий настроек, все они предназначены для определения вида текста на чертеже — текста при простановке размеров, позиций и т.п. Вы можете изменять сам шрифт, его стиль (обычный, курсив, полужирный), раз­меры условных обозначений (диаметры, квадраты и т.п.) в соответствие с ГОСТ 2.314-68.



  • Текст на чертеже. Данная настройка задает параметры текста на черте­же (текста технических требований, обозначений разрезов и сечений и т.д.). Вы можете изменить настройки по умолчанию — использовать другой шрифт, изменить его стиль (обычный, полужирный, курсив), раз­мер, выравнивание и т.д.;

  • Шероховатость. При помощи этой настройки вы можете задать парамет­ры текста, используемого при указании шероховатости;

  • Отклонения формы и база. Данная настройка определяет параметры шрифта, используемого при указании базы и простановке отклонений формы;

  • Заголовок таблицы. Эта настройка задает тип шрифта, используемого в заголовке таблицы;

  • Ячейка таблицы. Данный параметр задает настройки шрифта, который будет использоваться при заполнении ячеек таблицы;

  • Линия разреза сечения. Этот параметр определяет настройки шрифта, используемого при обозначении разрезов и сечений. Вы также можете из­менить шрифт, его стиль, размер и т.д.;

  • Стрелка взгляда. Данная настройка определяет параметры текста, ис­пользуемого при обозначении стрелки взгляда;

  • ^ Обозначение изменения. Данный пункт окна настроек имеет также ряд опций:

о Параметры. При помощи этой настройки вы можете задать тип знака, используемого для обозначения изменений на чертеже, и его высоту;

о Текст надписи. Данная настройка задает параметры текста, кото­рый будет использоваться при обозначении изменений. Вы можете изменить шрифта, его стиль, высоту и т.д.;

^ Параметры листа. Как видно из названия, все содержащиеся в данном
пункте настройки относятся к оформлению листа (рис. 1.37):

о Формат. При помощи этой настройки вы можете задать формат лис­та (от А5 до АО), определить его ориентацию (вертикально или гори­зонтально), либо задать другие размеры листа;

о ^ Вид. Данная настройка задает масштаб нового вида;

о Основная надпись. При помощи этой настройки вы можете задать, каким образом будет заполняться основная надпись (либо автомати­чески, по данным ассоциированной модели, либо вручную). Чтобы основная надпись заполнялась автоматически, поставьте галочку в окошке метки Синхронизировать основную надпись. Если же вы хотите заполнять ее вручную, то снимите галочку в этом окошке метки (рис. 1.38). При создании чертежа модели, ее масса автомати­чески рассчитывается и указывается в поле Масса чертежа. Если вы хотите заполнить данное поле вручную, то снимите галочку в окош­ке метки Синхронизировать значение массы, установленную по умолчанию. Здесь вы также можете задать единицы измерения мас­сы (килограммы, граммы ил и тонны), которые будут использовать­ся при заполнении поля Масса чертежа.

о Оформление. При помощи данного пункта настроек, вы можете вы­брать требуемый стиль оформления листа в соответствии с ГОСТ. По умолчанию используется схема оформления первого листа конструк­торского чертежа согласно ГОСТ 2.104-68. Однако, если необходимо



оформить лист иначе, то вы можете выбрать из доступных схем оформ­ления. Для того чтобы изменить оформление листа щелкните по тре­угольнику, расположенному справа от поля Название (рис. 1.39), и из выпадающего меню выберите нужный тип оформления;

о ^ Разбиение на зоны. Данная настройка позволяет задать разбиение формата на зоны. Вы можете определить тип линий и текста, кото­рые будут использоваться при работе в различных зонах;

о ^ Технические требования. При помощи этих настроек вы можете за­дать параметры текста и его форматирования при заполнении техни­ческих требований. Если вы хотите изменить настройки шрифта, то для этого щелкните по кнопке Шрифт, расположенной в правой час-





ти окна настроек (рис. 1.40). Откроется диалоговое окно, при помо­щи которого вы можете изменить тип шрифта, его размер, стиль (обычный, курсив, полужирный), высоту и т.д. Щелкнув по кнопке Табуляция, вы можете определить длину табуляции, используемое заполнение и выравнивание;

^ Неуказанная шероховатость. При помощи этой настройки вы може­те задать тип текста: шрифт, стиль, высоту, цвет и т.п., который будет использоваться при обозначении на чертеже шероховатости;

Таблица изменений. Данная настройка определяет разбиение табли­цы изменений на блоки. Если в окошке метки ^ Разбивать на блоки стоит галочка, то каждый элемент таблицы будет содержаться в своем собственном блоке. Если же эту галочку снять, то все элементы таблицы будут находиться в едином блоке;

Параметризация. Данная настройка касается возможности параметриза­ции моделей, что облегчает создание однотипных модификаций. По­скольку рассмотрение параметризации моделей выходит за рамки книги, мы не будем рассматривать данный пункт окна настроек рабочего стола.




Системы координат

В системе КОМПАС применяются ортогональные (декартовы) системы координат. При создании чертежа используется плоская система координат, ко­торая имеет две оси — ось абсцисс Ох и ось ординат Оу. При трехмерном моде­лировании добавляется еще одна ось — ось аппликат Оz. Также при создании пространственных моделей оперируют такими понятиями, как фронтальная, 13онтальная и профильная плоскости. Проекции на эти плоскости — это виды чертежа: вид спереди, сверху и слева соответственно.

Создание системы координат

В системе КОМПАС существует понятие глобальной и локальной систем координат. Вы можете создавать и удалять локальные системы координат, но не можете изменять глобальные.

Для того чтобы создать локальную систему координат:

  1. Создайте документ типа чертеж.

  2. Щелкните по кнопке (Локальная СК), расположенной на панели ин­струментов.

  3. Щелкните в том месте чертежа, где вы хотите поместить центр созда­ваемой системы координат, либо, воспользовавшись командным меню (рис. 1.41), в поле т введите координаты центра относительно глобаль­ной СК.



  1. Перемещая мышь, задайте угловое положение локальной системы ко­ординат относительно глобальной, или в поле Угол командного меню непосредственно введите это значение.

  2. Чтобы создать систему координат, щелкните правой кнопкой мыши и из появившегося меню (рис. 1.42) выберите прервать команду, либо щелкните по кнопке ..... расположенной в командном меню.



Резюме


Итак, первая часть книги позади. Теперь, для лучшего усвоения получен­ной информации, пора подвести первые итоги, сделаем обзор того, что вы уз­нали и чему научились.

^ Машинная графика — это самый современный способ проектирования из­делий в любой отрасли промышленности: начиная от швейного производства (можно использовать систему САПР, например, КОМПАС, для создания моде­лей одежды) и заканчивая наукоемкими отраслями техники и технологий, на­пример, точное приборостроение и т.д. Задачи, решаемые системами автома­тизированного проектирования, достаточно широки и разнообразны. Пакеты САПР обладают не только возможностями визуального моделирования изде­лий, но и выполнения необходимых расчетов. На российском рынке предлага­ется широкий спектр программных продуктов семейства САПР (AutoCAD, Solid Works и т.п.), однако наиболее мощным и максимально оптимизирован­ным средством автоматизированного проектирования является отечественный программный продукт, выпускаемый ЗАО «АСКОН» — КОМПАС-ЗБ V6.

Отличительной особенностью системы КОМПАС является оптимальное со­четание показателя производительность/системные требования. Так, вы сами можете оценить, что требования, выдвигаемые к аппаратным средствам не так уж значительны для сегодняшнего уровня развития компьютерных техноло­гий, но в то же время они способны обеспечить полномасштабную и комфорт­ную работу с этим программным продуктом.

Следующим этапом знакомства с КОМПАС был процесс установки данного пакета САПР на жесткий диск вашего компьютера. Вы, вероятно, обратили внимание и оценили, что столь мощный программный продукт очень просто установить на ваш компьютер — производители постарались максимально уп­ростить процесс установки и избавили вас от рутинной настройки бесконеч­ных опций: вместо этого вы должны лишь уточнить вариант установки в не­скольких диалоговых окнах, а остальную работу КОМПАС выполнит сам.

После того как система была успешно установлена на компьютер, вы запус­тили ее и познакомились с ее интерфейсом. Полагаем, вы не могли не заме­тить, что столь мощный программный продукт имеет широкие возможности настройки интерфейса, и это делает КОМПАС очень гибким средством проек­тирования, выгодно отличающим его от аналогичных САПР иностранных фирм-разработчиков.

Далее вы кратко познакомились с ^ Главным меню программы. Вы узнали, что оно является контекстным — набор пунктов в меню зависит от того, с до­кументом какого типа вы работаете. Также изучили назначение каждого из пунктов Главного меню и то, какие команды в них располагаются.

Так, в меню ^ Файл находятся основные команды работы с файлами доку­ментов (деталей, сборок, чертежей, фрагментов, спецификаций) и вывода их на печать. В меню Редактор — команды редактирования создаваемых вами документов. Меню Вид содержит команды и инструменты управления отобра­жения документов: так вы можете изменить масштаб отображения документа, если же вы работаете с трехмерной моделью, то при помощи команд этого меню вы можете изменить режим ее отображения (подробнее о режимах ото­бражения речь пойдет в следующей части книги).

Меню Сервис полностью соответствует своему названию — оно помогает вам осуществить необходимые настройки интерфейса и отдельных элементов при работе с документами. Здесь вы найдете такие команды, как Оформление чертежей, Настройка интерфейса, Стили линий и т.д. — то есть все команды, относящиеся к настройке любых элементов КОМПАС можно найти здесь.

Как видно из названия, пункт меню Библиотеки предназначен для работы с прикладными библиотеками программного продукта (более подробно с наи­более часто используемыми библиотеками КОМПАС вы познакомитесь в по­следующих частях на конкретных примерах разработки моделей и чертежей). Наличие таких библиотек помогает существенно упростить и сделать макси­мально комфортным и эффективным процесс проектирования. Так, достаточ­но отметить, что в КОМПАС есть библиотека стандартных крепежных элемен­тов. И это является значительным преимуществом данного программного про­дукта. Люди, работавшие с системой AutoCAD, согласятся с нами, что в КОМПАС нет необходимости при разработке изделий самостоятельно созда­вать каждый винтик, болтик, шайбу, штифт и т.д., чем вынуждены занимать­ся проектировщики, использующие аналогичные САПР иностранных произ­водителей. Важно еще раз подчеркнуть, что система автоматизированного проектирования КОМПАС построена с учетом российских стандартов. Таким образом, использование стандартных элементов в разрабатываемых изделиях позволяет сэкономить массу времени — чтобы использовать стандартный эле­мент, просто укажите его ГОСТ и ряд основных характеристик, остальное КОМПАС сделает сам.

Как вы помните, ^ Главное меню КОМПАС является контекстным. Так, не­которые его пункты будут отображаться только лишь при работе с некоторы­ми документами (например, Вставка, Спецификации, Операции и т.д.), в них вы можете найти команды, необходимые для работы именно с этими типами документов.

И заключительным этапом при прочтении этой части было знакомство с типами документов и выполнением основных настроек рабочей области. Так, вы узнали, что в КОМПАС существует шесть типов документов — Деталь, Сбор­ка, Чертеж, Фрагмент, Текстовый документ и Спецификация. Каждый из документов при сохранении получает имя и расширение. При этом имя задаете вы, а расширение создается автоматически в зависимости от типа сохраняе­мого документа, если вы сохраняете документ типа Чертеж, то расширение файла будет .cdw, а при сохранении Спецификации — .spw и т.д.

Вы научились создавать различные типы документов и выполнять настрой-- л формата чертежа, при помощи окна Параметры, вкладки Текущий чертеж. Так, при помощи данного окна вы можете настроить вид отображения стрелок, текста, размерных линий, надписей и специальных обозначений на чертеже, размеры формата. Вы узнали, как можно изменить тип основной надписи : рамки. И, наконец, научились основам работы с системами координат.

Теперь, когда вы получили достаточно увесистый багаж начальных знаний, необходимых для работы с КОМПАС, можно уже подумать и о переходе непосредственно к созданию моделей и построению чертежей. Но перед тем, как сделать это, советуем ответить на контрольные вопросы и выполнить несложные задания, дабы проверить, как хорошо вы усвоили материал. Если при от­ветах на некоторые вопросы у вас возникнут сложности, советуем вам вернуть­ся к нужному разделу и еще раз внимательно его перечитать. Помните, чтобы в полной мере овладеть эффективным проектированием в среде КОМПАС, нужно внимательно изучить предлагаемый вам материал.

Если же у вас не возникло трудностей с контрольными вопросами и зада­ниями, то можете смело переходить к изучению материала следующей части!


Контрольные вопросы


  1. Что такое машинная графика?

  2. Что такое САПР?

  3. Какие САПР вы знаете?

  4. С чего, как правило, начинают построение объемной детали?

  5. Что такое эскиз и для чего он используется?

  6. Что такое привязки? Для чего они нужны?

  7. Какие существуют виды привязок? Чем они отличаются?

  8. Что такое Прикладные библиотеки! Расскажите, как и для чего их ис­пользуют.

  9. Как называется элемент интерфейса КОМПАС, где располагаются ос­новные команды управления и создания документов?

  10. Охарактеризуйте кратко каждый из пунктов Главного меню.

  11. Какие типы документов КОМПАС вы знаете?

  12. Как создать новый документ?

  13. Как настроить рабочую область чертежа?

  14. Какие системы координат используются в КОМПАС?

  15. Как создать локальную систему координат?



Похожие:

Рабочем Столе, или выбрать одноименную коман­ду из меню Пуск iconТекстовый процессор Microsoft Word. Назначение, запуск, вид рабочего окна
Для того, чтобы запустить w необходимо дважды щелкнуть мышью по соответствующему значку на Рабочем столе или выбрать в главном меню...
Рабочем Столе, или выбрать одноименную коман­ду из меню Пуск iconЭлектронная таблица Microsoft Excel. Основные понятия
Для того чтобы запустить электронную таблицу Excel следует выполнить двойной щелчок мышью по соответствующему значку на Рабочем столе...
Рабочем Столе, или выбрать одноименную коман­ду из меню Пуск iconПрактическая работа Система счисления Задание Перевод чисел в позиционных системах счисления
Запустить программу Калькулятор командой главного меню [Пуск – Программы – Стандартные = Калькулятор]
Рабочем Столе, или выбрать одноименную коман­ду из меню Пуск iconКонкурс «здоровичок»!
Диаграмма может находиться на рабочем листе вместе с исходными данными или на отдельном листе диаграмм, который является частью книги....
Рабочем Столе, или выбрать одноименную коман­ду из меню Пуск iconОсновы православной культуры
Не всё в своей жизни человек может выбрать сам. Я не могу выбрать своих родителей. Я не могу выбрать язык, на котором мама пела мне...
Рабочем Столе, или выбрать одноименную коман­ду из меню Пуск iconФункции Picture Motion Browser
Если дважды щелкнуть на рабочем столе значок [] (Picture Motion Browser), запустится [Picture Motion Browser]
Рабочем Столе, или выбрать одноименную коман­ду из меню Пуск iconИнструкция по заполнению шаблона
В меню ms excel 2003: Сервис ¦ Макрос ¦ Безопасность ¦ выбрать нижний пункт «Низкая безопасность» ¦ «OK»
Рабочем Столе, или выбрать одноименную коман­ду из меню Пуск iconИнструкция по заполнению шаблона
В меню ms excel 2003: Сервис ¦ Макрос ¦ Безопасность ¦ выбрать нижний пункт «Низкая безопасность» ¦ «OK»
Рабочем Столе, или выбрать одноименную коман­ду из меню Пуск iconИнструкция Обновление Лог обновления Справочники Производственная Комментарии Проверка
В меню ms excel 2003: Сервис ¦ Макрос ¦ Безопасность ¦ выбрать нижний пункт «Низкая безопасность» ¦ «OK»
Рабочем Столе, или выбрать одноименную коман­ду из меню Пуск iconИнструкция Обновление Лог обновления Справочники Производственная Комментарии Проверка
В меню ms excel 2003: Сервис ¦ Макрос ¦ Безопасность ¦ выбрать нижний пункт «Низкая безопасность» ¦ «OK»
Разместите кнопку на своём сайте:
Документы


База данных защищена авторским правом ©lib3.podelise.ru 2000-2013
При копировании материала обязательно указание активной ссылки открытой для индексации.
обратиться к администрации
Лекции
Доклады
Справочники
Сценарии
Рефераты
Курсовые работы
Программы
Методички
Документы
Документы